• Announcements

    • UnderDawg

      A Few Simple Rules   05/22/2017

      Sailing Anarchy is a very lightly moderated site. This is by design, to afford a more free atmosphere for discussion. There are plenty of sailing forums you can go to where swearing isn't allowed, confrontation is squelched and, and you can have a moderator finger-wag at you for your attitude. SA tries to avoid that and allow for more adult behavior without moderators editing your posts and whacking knuckles with rulers. We don't have a long list of published "thou shalt nots" either, and this is by design. Too many absolute rules paints us into too many corners. So check the Terms of Service - there IS language there about certain types of behavior that is not permitted. We interpret that lightly and permit a lot of latitude, but we DO reserve the right to take action when something is too extreme to tolerate (too racist, graphic, violent, misogynistic, etc.). Yes, that is subjective, but it allows us discretion. Avoiding a laundry list of rules allows for freedom; don't abuse it. However there ARE a few basic rules that will earn you a suspension, and apparently a brief refresher is in order. 1) Allegations of pedophilia - there is no tolerance for this. So if you make allegations, jokes, innuendo or suggestions about child molestation, child pornography, abuse or inappropriate behavior with minors etc. about someone on this board you will get a time out. This is pretty much automatic; this behavior can have real world effect and is not acceptable. Obviously the subject is not banned when discussion of it is apropos, e.g. talking about an item in the news for instance. But allegations or references directed at or about another poster is verboten. 2) Outing people - providing real world identifiable information about users on the forums who prefer to remain anonymous. Yes, some of us post with our real names - not a problem to use them. However many do NOT, and if you find out someone's name keep it to yourself, first or last. This also goes for other identifying information too - employer information etc. You don't need too many pieces of data to figure out who someone really is these days. Depending on severity you might get anything from a scolding to a suspension - so don't do it. I know it can be confusing sometimes for newcomers, as SA has been around almost twenty years and there are some people that throw their real names around and their current Display Name may not match the name they have out in the public. But if in doubt, you don't want to accidentally out some one so use caution, even if it's a personal friend of yours in real life. 3) Posting While Suspended - If you've earned a timeout (these are fairly rare and hard to get), please observe the suspension. If you create a new account (a "Sock Puppet") and return to the forums to post with it before your suspension is up you WILL get more time added to your original suspension and lose your Socks. This behavior may result a permanent ban, since it shows you have zero respect for the few rules we have and the moderating team that is tasked with supporting them. Check the Terms of Service you agreed to; they apply to the individual agreeing, not the account you created, so don't try to Sea Lawyer us if you get caught. Just don't do it. Those are the three that will almost certainly get you into some trouble. IF YOU SEE SOMEONE DO ONE OF THESE THINGS, please do the following: Refrain from quoting the offending text, it makes the thread cleanup a pain in the rear Press the Report button; it is by far the best way to notify Admins as we will get e-mails. Calling out for Admins in the middle of threads, sending us PM's, etc. - there is no guarantee we will get those in a timely fashion. There are multiple Moderators in multiple time zones around the world, and anyone one of us can handle the Report and all of us will be notified about it. But if you PM one Mod directly and he's off line, the problem will get dealt with much more slowly. Other behaviors that you might want to think twice before doing include: Intentionally disrupting threads and discussions repeatedly. Off topic/content free trolling in threads to disrupt dialog Stalking users around the forums with the intent to disrupt content and discussion Repeated posting of overly graphic or scatological porn content. There are plenty web sites for you to get your freak on, don't do it here. And a brief note to Newbies... No, we will not ban people or censor them for dropping F-bombs on you, using foul language, etc. so please don't report it when one of our members gives you a greeting you may find shocking. We do our best not to censor content here and playing swearword police is not in our job descriptions. Sailing Anarchy is more like a bar than a classroom, so handle it like you would meeting someone a little coarse - don't look for the teacher. Thanks.

Archived

This topic is now archived and is closed to further replies.

Timo42

SQL error locking me out of forums

53 posts in this topic

mySQL query error: DELETE FROM ipb_sessions WHERE member_id=23512

 

is what I get when I click on the forum tab on the front page or type in the address.

 

For some reason my log in locks me off SA, can't even see the forums as a guest. :blink: I get an SQL error after using my log in once on a computer, sent a message from the f/p to Scot, he isn't seeing any issue on his end, and no one else is complaining, :( maybe someone else has an answer. If I could figure out how to clear it, it wouldn't be as much of an issue. I even tried downloading Chrome and Firefox, one time and down, some kind of supercookie. My wife's log in worked, until I switched to mine, then her computer wont load the forums any more, all I can see is the mythical Front page, I must be in some alternate universe where the front page exists and the forums don't. I'm using someone elses computer now, after I send this, I won't be able to see the forums any more on it. Weird.

Share this post


Link to post
Share on other sites

Trying to reply to see if It locks up when I change forums, this is only happening with SA.

Was able to post this, but if I go to ga I will be locked out again.

Share this post


Link to post
Share on other sites

Ok, if I use a proxy server, I can read the forums, can even sign in again, don't know how long or if it will still lock out, weird thing I noticed was that even clicking on my avatar will give you an SQL error, but not lock you out of the forum. Try it. You definitely have something going wrong at your end, once you figure out what it is, maybe slap it on BG?

Share this post


Link to post
Share on other sites

JK about giving this bug to Gator, it's a real pita. Seems like a proxy server is a work around. Maybe corrupt data in the member files?

Share this post


Link to post
Share on other sites

Warning: mysqli_query() [function.mysqli-query]: (HY000/1194): Table 's' is marked as crashed and should be repaired in /home/forumss/public_html/ips_kernel/classDbMysqliClient.php on line 234

 

 

Got this message when I clicked on my avatar in the member list, maybe someone knows what that means, sounds like a pretty specific problem.

Share this post


Link to post
Share on other sites

Has the thought ever occurred to you that perhaps God hates people leaving their boats in their front yard?...

Share this post


Link to post
Share on other sites

Has the thought ever occurred to you that perhaps God hates people leaving their boats in their front yard?...

if you're Dawgs replacement, we're doomed :lol:

Share this post


Link to post
Share on other sites

<p>

Has the thought ever occurred to you that perhaps God hates people leaving their boats in their front yard?...

if you're Dawgs replacement, we're doomed Oi8vZm9ydW1zLnNhaWxpbmdhbmFyY2h5LmNvbS9wdWJsaWMvc3R5bGVfZW1vdGljb25zL2RlZmF1bHQvbGF1Z2gucG5n

 

Better than a Cosmopolitan Red Scout. ;)

Share this post


Link to post
Share on other sites

Warning: mysqli_query() [function.mysqli-query]: (HY000/1194): Table 's' is marked as crashed and should be repaired in/home/forumss/public_html/ips_kernel/classDbMysqliClient.php on line 234

 

This is what I get on Chrome with my real log in. No problem with this sock.

Share this post


Link to post
Share on other sites

Knock, knock, Is this thing on? Anybody?

 

Still messed up, doesn't matter what computer or isp, starting to feel like Fred with these multiple identities and all. :wacko: Sock works fine , no issues at all.

Share this post


Link to post
Share on other sites

mySQL query error: SELECT m.*, m.member_id as my_member_id,p.*,pp.*,g.*,s.*,ccb.cache_content FROM ipb_members m LEFT JOIN ipb_pfields_content p ON ( p.member_id=m.member_id )

LEFT JOIN ipb_profile_portal pp ON ( pp.pp_member_id=m.member_id )

LEFT JOIN ipb_groups g ON ( g.g_id=m.member_group_id )

LEFT JOIN ipb_sessions s ON ( s.member_id=m.member_id )

LEFT JOIN ipb_content_cache_sigs ccb ON ( ccb.cache_content_id=m.member_id ) WHERE m.member_id=23512

This is not a problem with IP.Board but rather with your SQL server. Please contact your host and copy the message shown above.

 

This is what I get when I mouse over my name now.

Share this post


Link to post
Share on other sites

Maybe this is connected somehow. I can't get into Cruising Anarchy right now, all I get is a Yahoo page saying it doesn't exist:

 

Yahoo! - Help

Sorry, the page you requested was not found.

 

Please check the URL for proper spelling and capitalization. If you're having trouble locating a destination on Yahoo!, try visiting the Yahoo! home page or look through a list of Yahoo!'s online services. Also, you may find what you're looking for if you try searching below.

 

 

I'm used to the forums disappearing for a while altogether, but I can get into any other of the SA sites, and I can go through history view and go back into specific topics in CA, I just can't get to the CA index. WTF?

Share this post


Link to post
Share on other sites

Testing testing 123

 

:(

Wasn't the avatar picture.

 

 

Warning: mysqli_query() [function.mysqli-query]: (HY000/1194): Table 's' is marked as crashed and should be repaired in /home/forumss/public_html/ips_kernel/classDbMysqliClient.php on line 234

 

 

 

 

SQL Error

Share this post


Link to post
Share on other sites

I'm getting that SQL error message pretty frequently and it says to copy the message above and pass it to my host. Except that the box that should contain the "message above" is blank.

Share this post


Link to post
Share on other sites

I asked my web guru wife about the error message. Her reply:

 

It's not a problem with YOUR SQL server. It's a problem with Sailing Anarchy's SQL server.

 

Either the SQL server keeps going down, or there's some sort of database connection problem, or their hosting company keeps screwing something up. Could be the site's simply getting too busy for its SQL server to keep up with, or if they're on shared hosting it could be an entirely separate, unrelated site that keeps bringing down the server.

 

Share this post


Link to post
Share on other sites

Getting the same as well at times, I use the time to get on with some work.

Share this post


Link to post
Share on other sites

I asked my web guru wife about the error message. Her reply:

 

It's not a problem with YOUR SQL server. It's a problem with Sailing Anarchy's SQL server.

 

Either the SQL server keeps going down, or there's some sort of database connection problem, or their hosting company keeps screwing something up. Could be the site's simply getting too busy for its SQL server to keep up with, or if they're on shared hosting it could be an entirely separate, unrelated site that keeps bringing down the server.

 

 

Seems to be happening every morning around 0830 EST or so.

 

I know Scot's been in touch with the propeller heads at the hosting company, they can't seem to replicate it but suspect that's because the only way you CAN is to try and access the boards around 0815-0845 EST. So they need to set an alarm and try it.

 

May well be something like a batch job/backup/etc. that either consumes system resources OR locks things in the database when it happens.

Share this post


Link to post
Share on other sites

I got it once earlier in the week (for twenty-ish minutes), and then today at 0530 PDT on both the lappy and the EyeFone (same IP addy) for about 15.

 

I blame that fuker in Crawford......

Share this post


Link to post
Share on other sites

I got it once earlier in the week (for twenty-ish minutes), and then today at 0530 PDT on both the lappy and the EyeFone (same IP addy) for about 15.

 

I blame that fuker in Crawford......

 

That would be at about 0830 EST.

 

Or technically Atlantic Time, where I am sitting.

Share this post


Link to post
Share on other sites

I got it once earlier in the week (for twenty-ish minutes), and then today at 0530 PDT on both the lappy and the EyeFone (same IP addy) for about 15.

 

I blame that fuker in Crawford......

 

That would be at about 0830 EST.

 

Or technically Atlantic Time, where I am sitting.

 

IST?

 

 

 

 

 

 

 

 

 

 

 

 

 

(Island Slacker Time?)....

Share this post


Link to post
Share on other sites

Yep. Pretty routinely around 0830 EDT. Seeing it from multiple computers and servers. I just go away for 10-15 minutes and its back. Seems when it comes up the boats is uber slow for a few minutes while other forums, pages are still fast so not my connection.

 

Goes with the eternal "saving post" when trying to post. Last "upgrade" wasn't.

Share this post


Link to post
Share on other sites

Yep. Pretty routinely around 0830 EDT. Seeing it from multiple computers and servers. I just go away for 10-15 minutes and its back. Seems when it comes up the boats is uber slow for a few minutes while other forums, pages are still fast so not my connection.

 

Goes with the eternal "saving post" when trying to post. Last "upgrade" wasn't.

 

I'm guessing there is something running - a backup or system event, which has not reached completion at this time. If it's hosted in California, that's still oh-dark-thirty there and not a bad time for system events...but it's too late for the East Coast.

 

I've not seen it earlier than 0830 EST, but I've not always looked.

Share this post


Link to post
Share on other sites

BJ, it happened again this morning before I read this post and I did not note the time, but it was probably in the window of time you noted above.

 

I just looked at the time that I sent the email about it to my wife and it was 8:30 am. That was within minutes after it happened on 3/23/13.

Share this post


Link to post
Share on other sites

It still locks up with the sql error any time I try to log in as Timo42 at home, If they want to duplicate the problem, all they have to do is click on the avatar pic in this thread. I got a feeling that I'm not the only one with the issue, but the other ones it has happened to just have gone away rather than bother with it.This isn't rocket surgery... :rolleyes:

Share this post


Link to post
Share on other sites

Happened again yesterday at 0530-ish. But didn't see it this morning at 0615....

Share this post


Link to post
Share on other sites

Happened again yesterday at 0530-ish. But didn't see it this morning at 0615....

 

If it's any consolation, I am also getting a MS SQL Server error for Maxsea, right before it pukes.

Share this post


Link to post
Share on other sites

Happened again yesterday at 0530-ish. But didn't see it this morning at 0615....

 

If it's any consolation, I am also getting a MS SQL Server error for Maxsea, right before it pukes.

 

Hmmm, was just out for at least 15 minutes just now. 1515---1530 PDT.

 

Odd, innit?....

Share this post


Link to post
Share on other sites

Note the time (in the upper right corner) on this screen shot:

 

SA-sql-server-error.gif

 

Yup, that's the one that I get----and when you hit Return To Index......it doesn't....

Share this post


Link to post
Share on other sites

Trying this one out again, lets see how long till it locks up.

Share this post


Link to post
Share on other sites

Still working on IE, was on Chrome before...

 

Will try it at home.

Share this post


Link to post
Share on other sites

No, happened again last night, 10pm

What time zone?

Share this post


Link to post
Share on other sites

When threads get over 100 pages & are full of huge file size pics, the board goes screwey.

Share this post


Link to post
Share on other sites

BJ, I think mad is in England.

 

atefooterz, I haven't noticed any particular problem with the Cruising Anarchy Sliver thread, which is nearing 5k replies and has lots of pics. The problem here seems to affect all forums, all threads.

Share this post


Link to post
Share on other sites

Well the forums were down completely here last night for a couple of hours, but this log in hasn't locked up. :)

Share this post


Link to post
Share on other sites

I had one on my phone last night around 6pm EST. Message was something like "SQL error. This error is not on the boards but on your end" there were more words but it was something like that. The other websites I tried, including other forums worked fine. By the time I tried it on my computer around 7pm EST, things were back working.

Share this post


Link to post
Share on other sites

Slick, my wife explained that error message to me. It's saying that the problem is not with the IP Board software, but with Sailing Anarchy's servers. So not really "your end" but not the software either. BJ said that SA's hosting company is working on trying to figure it out.

Share this post


Link to post
Share on other sites

Thanks Tom. First I'd seen that error, but I remembered this thread popping up in the new content feed so I thought I'd pile on.

 

Good to know it's being looked into. I'd sure hate to be stuck doing something productive...

Share this post


Link to post
Share on other sites

Slick, my wife explained that error message to me. It's saying that the problem is not with the IP Board software, but with Sailing Anarchy's servers. So not really "your end" but not the software either. BJ said that SA's hosting company is working on trying to figure it out.

 

Specifically, it's not SA's servers, but rather the Database server.

 

All the posts, user data, etc. are stored in a large relational database on MySQL, a type of relational database server. The board runs on a Web Server, those pages use a scripting language to make requests of the database, the database sends back the data to the web site that makes it pretty for your browser. These two servers can (and should, on a busy site) be located on two physically different pieces of server hardware.

 

So when you click the link on a thread, instead of it loading a web page of static text, the database returns all the content and the page is built on the fly.

 

What is happening is that the BBS Software is asking the SQL Database for things, and the SQL database is intermittently hurking up a hairball instead of returning the requested data.

 

The question is WHAT is making the SQL Database choke. It could be something as simple as too much demand on the database server, or a process or query that locks part of the database temporarily, blocking requests against it until the lock is released. Some system functions (e.g. re-building table indices to increase performance, some sort of backup utilities) can cause those sorts of locking on a whole table or large chunks of it. Also badly written database code can do it, but most modern SQL databases are smart enough to manage "deadlocks" and kill them even if developers are too sloppy too - and that shouldn't happen at the same time every day.

 

The largest trick here, since this is intermittent and not consistently reproduce-able, is to get the tech support propellerheads to actually witness the problem so they can take a look under the hood to see what else is running.

Share this post


Link to post
Share on other sites

They must have fixed something, I'm not crashing. :ph34r::)

Share this post


Link to post
Share on other sites

They must have fixed something, I'm not crashing. :ph34r::)

 

You've been re-in-carnationed. WFD....

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

woman-with-a-carnation-oleksiy-maks.jpg

Share this post


Link to post
Share on other sites

Note the time (in the upper right corner) on this screen shot:

 

SA-sql-server-error.gif

 

+1 Seeing that often. Today early am after sunup. I just go some place else on the web and check back later. Been seeing it for a while. Next time Ill check if its 0830 Eastern daylight time..

Share this post


Link to post
Share on other sites

Warning: mysqli_query(Bull Gaytor) [function.mysqli-query]: (HY000/1194): Table 's' is marked as crashed and should be repaired in/home/forumss/public_html/ips_kernel/classDbMysqliClient.php on line 234

 

This is what I get on Chrome with my real log in. No problem with this sock.

 

????????????????? :o

Share this post


Link to post
Share on other sites

I remember this happening with one of the older versions, turned out the time was associated with a backup operation. I've seen it a few times, recently, but goes away quick enough so have never bothered complaining....

Share this post


Link to post
Share on other sites



SQL Error



An error occured with the SQL server:


This is not a problem with the IPS Community Suite but rather with your SQL server. Please contact your host and copy the message shown above.



Return to the index


Share this post


Link to post
Share on other sites