Jump to content

st1000+ and opencpn anybody sucessfully connect


Recommended Posts

Has anybody sucessfully sent nmea 183 from opencpn to an st1000+ autopilot? I have tried every combination of connecting output from opencpn to drive autopilot. Will not enter track mode. Help anyone? I see the nmea sentences outputting to the comm port, yet will not enter track mode.

Link to post
Share on other sites

Why would someone use track mode with this tiller pilot? I can answer that:

1 – deliveries with your motor

2 – sails up and you have no wind data available

I have an ST2000+ on my boat and have it connected to NMEA0183 data from iNavX, via a multiplexer. I found a few things with this when making it work. The keystrokes needed to invoke Track Mode can be a bit counter intuitive. If you get the rapid beeping alarm after pressing -10/+10 make sure to press them together again to turn on Track Mode. The alarm is telling you the data is being received. Also the numbers on the bulkhead plug socket are ridiculously small and hard to read, making it easy to mis-wire.

Isn't OpenCPN a piece of software? What hardware is sending the data to the ST1000+? One thing I learned working on my setup is how inconsistently various bits of hardware adhere to the NMEA0183 standards.

  • Like 1
Link to post
Share on other sites

Opencpn is receiving nmea data from a gps and position is plotted by opencpn.  I configure an output port from opencpn and set it up to send autopilot b sentences xte range and bearing to waypoint. I see the sentences being output on the comm port . I have checked with voltmeter at the autopilot connection and can see voltage fluctuate. I have connected to pin 5 and 6 at the autopilot. Have tried reversing polarity. i have used pin 2 and 5 of the serial output to  5 and 6 of the autopilot connector. can anyone help?

Link to post
Share on other sites

I thought pin 3 was TxD on a PC ... dongle would be the same? But maybe I have forgotten how that ancient tech works. And RS-232 is not NMEA 0183 so one wires up some hack at one end or the other...

Link to post
Share on other sites
11 minutes ago, xyzzy said:

What happens when you push the buttons for track mode?  It should at least show that it's waiting for track data over nmea.

 

On 11/17/2020 at 11:17 AM, DaveyJones said:

. i have used pin 2 and 5 of the serial output

Not if he connected RX from the computer. TX is on pin 3.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...