Jump to content

Simrad TP32 Autohelm


Recommended Posts

My autohelm stopped working on the weekend. I've had the boat for a couple of months now, and the Simrad TP32 came with the boat. Never used one before, but didn't take long to fall in love with it, so I'm very disappointed! Just wondering if anyone has experiences that might help me because Simrad aren't interested in repairing - but will happily charge me almost full retail to replace it! 

Normally I only use it for holding a course and for small course changes, but I tried to auto-tack on the weekend and it wouldn't do it, and since then it hasn't worked. Won't even adjust the length of the rod while in standby (ie motor shows no sign of operating).

Any tips on repair or resetting? Can the motor be easily replaced?

Link to post
Share on other sites

I would check for 12V power at the plug and corrosion at the plug. What you describe could be just a weak connection (computer gets confused) / low voltage. Then the connection gets a little worse and nothing happens.

 

Link to post
Share on other sites
5 hours ago, Zonker said:

I would check for 12V power at the plug and corrosion at the plug. What you describe could be just a weak connection (computer gets confused) / low voltage. Then the connection gets a little worse and nothing happens.

 

That's what I'm hoping!

Link to post
Share on other sites

Autohelm now working! Tried a reset button combination I found in another forum. VERY annoyed that Simrad's Aussie distributors didn't mention anything about a reset option despite me specifically asking in the email if there was something I should try before sending it for repairs! They were fully focused on me buying a new replacement :angry:

  • Like 1
Link to post
Share on other sites
On 9/10/2021 at 11:04 AM, harrygee said:

Well done.

How about sharing your new knowledge?

Cheers

Power off, hold down left, right, nav and tack buttons and power on while holding down. Of course, it could also have just been the extended off period that allowed the system to discharge and reset on power up ;)

Link to post
Share on other sites
  • 2 weeks later...

Holy crap! I just stumbled across page 17 in that manual...
 

Quote

The PCB Assembly is a common item to all Wheelpilots and Tillerpilots. However, when the PCB is used in the TP10 or WP10 those components concerned with NMEA and CANBUS data are present but not in use,[...]

and the table at the bottom of the page that shows all of the solder connections to turn a TP10 into a TP20. (Well, that and a cable.)

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...